Appcelerator Now has a Solution for the X509TrustManager Android Problem

Start testing your apps now - important!

Posted by Malcolm Hollingsworth on

Please read the earlier article to fully understand the situation.

What do you need to do?

If you are using Ti SDK 5.0.2.GA target Android API 22 or higher, for all newer Ti SDK versions target Android API 23 or higher.

If you use an earlier version?

You will need to download a matching patch build as follows;

Things you should know

  • Always aim to target the latest safe Android API level.
  • Make sure your server SSL certificates work - no more faking it.
  • Submit early to the Play Store, problems cannot easily be fixed after the deadline of May 17, 2016.

Things you should really know

It seems some of you have been building apps as a development build and submitting that to the Android Play Store.

STOP IT!

There is a reason why there are different categories. If you still think you know better; you are wrong.


Appcelerator has a blog post on the subject: